
Microsoft Access II 
 
1.) Opening a Saved Database 

 Open the Music database saved on your computer’s hard drive. *I added more songs and 
records to the Songs and Artist tables.  

 Click the Options button next to the Security Warning.  

 Select Enable this Content. 

 Click OK. *The Security Alert box enables Access to provide higher security when opening a 
database. The database will open in the backdrop view in quarantine until you enable the 
content.  

 
2.) Creating Sub Forms (Forms Continued) 

 Click on the Album Table in the Navigation Pane.  

 Click the Create Tab -> Form command button.  

 The Form “Album 1” will appear. This form is split into two parts because we have the 
relationship between the Song Table and the Album Table. In other words, we have the album 
form with the songs table attached. *You may also notice that only songs attached to a 
particular album is displayed on the form. For example, the Aphrodite record will display only 
songs from that album. 

 You may also notice that there are two 
record navigation task bars.  

 It is extremely important to recognize  
the difference between the two navigation task bars. One is navigate through the album records 
the other is to navigate through song records. *As you search through albums, you may notice 
that only songs belonging to a particular album will appear in the form.  

 Click the Save Diskette in the Quick Access Toolbar. Save the Form as Album w/ Songs. 

 Go to the Design View.  

 Click inside the Table.Songs box (at the bottom of the form) and hit the Delete Key on your 
keyboard.  

 The Table.Songs box will disappear.  

 Now, drag and drop the Songs Form below the Album Cover field. You may want to move the 
Songs Form to a position that lines up with the Album fields. Click on the Songs Form and orange 
box will appear around it. Simply click on the orange line and drag and drop the form to line up 
with the Album fields.  

 Now go back to the Form View. 

 We just replaced the Songs Table with the Songs Field!     
     Design View with Songs Table below Album fields 

 
 
 
 
 
 
 
 
 



3.) Customizing Forms with AutoFormat, Logos, Editing Options 

 You may change the look of the Album w/ Songs form by clicking View -> Layout View. 

 In the Format Tab -> AutoFormat Group there are several formats in the gallery. Simply mouse 
over each gallery to preview the new design.  

 For this class, let’s select the Flow gallery. The Album form will change design. *We will discuss 
changing the sub form later in this lesson! 

 Save your changes here! (Click the save diskette in the Quick Access Toolbar) 

 Logos: 

 To add a custom logo, go to the Design View.  

 Click the Logo icon on the form.  

 Click the Logo Command button in the Design Tab.  

 Find the logo provided in the class in the documents folder. Musiclogo.jpg 

 Click on the logo and click Open to attach the icon.  

 You may resize the logo by grabbing the fill handles and stretching the picture. (This is covered 
in-depth in the Word and Excel classes).  

 Save your changes here!  

 Sub Forms: 

 Change the view to the Design View.  

 Click on the Songs Sub Form -> in the Design Tab -> Tools Group -> Click the Subform in New 
Window command button.  

 Add the same logo icon and change the AutoFormat to Flow in the Arrange Tab. 

 Save your form and close the Songs Table.  

 The Songs sub form should now match the Album Form. Go back to Form View.  

 Editing: 

 With the Album w/ Songs form open, return to the Design View.  

 In the Form Header, you can change the title simply by 
clicking into the header. Change the “Album” text to 
Complete Album. *Notice ONLY the form title changes, not 
the entire form! 

 In the Album Title field, on the form the right column box, 
change the album title to Bold and a size 20 font.  

 Change the font style to Cooper Black.  

 Save the form and return to the Form View.  

 Return to the Design View. *Both the Songs and Album Form 
have an Album ID field. This is repeative data that is not 
needed.  

 Left click on the field title: Album ID. 

 This will highlight the entire field. Hit the Delete Key on the 
keyboard and the field will disappear.  

 Save the form and return to the Form View.  
 
4.) Buttons and Printing  

 Buttons: 

 You may add buttons to forms that allow easy navigation between forms and/or easier data 
entry.  

 In the Album w/Songs form, go back to the Design View. 



 In the Design Tab -> Controls Group there is a Button Command.  

 Click the Button Command button.  

 You will have to draw a button on the form. Draw a button to the right of the Album Title field.  

 The Command Button Wizard dialogue box will appear.  

 In the Categories box, select Record Navigation. 

 In the Actions box, select Find Record -> Click Next.  

 Select the Text button and type “Find Record” -> Click Next 

 In the meaningful name box, name the button “Find Record.”  

 Click Finish 

 The Find Record button will appear on the form.  

 Go back to Form View.  

 Click the Find Record button in the Form View.  

 Change the “Find What” field to Brave  

 In the Look In field, change it to “Album w/ Songs.” -> Click Find Next. 

 The album Brave should appear in the form. -> Click the Cancel Button.  

 Printing: 

 There are two ways to print forms.  

 1. You may click the Office Button -
> Print -> Print Preview to view the 
form on how it will look like when it 
prints. Now, if you are happy with 
the form simply click print! 

 2. You may create a print button 
right on the form. 

 Go Back to the Design View.  

 Click the Button Command in the 
Design Tab in the Ribbon. 

 Draw a button below the “Find Record” button on the form.  

 In the Command Button Wizard dialogue box -> Under Categories, change to Form Operations. 

 In the Actions box, change this to Print Current Form -> Click Next. 

 Click the Next button again! *This will place the printer icon on the button.  

 Change the meaningful name box to “Print” -> Click Finish 

 Go back to the Form View. 

 Click the Printer Button -> The Print dialogue box will appear ready for you to print!  
 
5.) Split Forms 

 So far we have created forms from the form wizard and sub-forms. However, what if we want a 
form of our album plus a list of the songs on that particular album. We will need to create a split 
form/table.  

 Click on the Album Table in the Navigation Pane. Make sure all tables and forms are closed! 

 Click the Create Tab -> Split Form command button.  

 The Album form and Album table will appear. However, this is not what we want. We need the 
Album Form with the Songs Table.  

 Go to the Design View.  

 Drag the Footer bar down to open up room under the “Format” field. You will now have enough 
room to drag the Songs Table from the Navigation Pane to the form.  



 Drag the Songs Table 
from the Navigation 
Pane and drop it 
below the format 
field in the form.  

 The SubForm Wizard 
dialogue box will 
appear.  

 Select the option: 
“Chose from a list” 

 Highlight the option: 
“Show Songs for 
each record in 
Album using Album 
ID”  

 Click Next. 

 Name the new form “Album Songs”  

 Click Finish.  

 Now you may want to resize the Album Songs form to match the Album form! 

 Go back to the Form View. 

 The Album Songs table will appear behind the original split form. (Rather the Album Songs table 
will appear behind the Album table.) 

 Grab and drag the blue Album Table view bar and 
drag it to the bottom of the form. 

 Navigate through Album Form and notice that  
each album has only their songs attached to their 
forms! In other words, we just created a form for 
each album and each album has their songs attached 
to their form.  

 SAVE HERE! Name the form “Complete Album” 
*Complete Album will appear under the album 
section in the Navigation Pane 

 
 
 
6.) Queries  

 Queries are like asking the database a question. You can combine information from multiple 
tables in a relational database to get information you need. Such as, filtering the database to list 
all the digital music with songs and artist information. In order to create a query, you need to 
think about the situation and criteria to set the query. For example, I want to create a query that 
will show all my digital songs in a datasheet.   

 Close all forms and tables. 

 Create Tab -> Query Design Command Button.  

 The Query Design and the Show Table Dialogue Box will appear. 

 In the Show Table box, this is where we need to select the tables in which have the fields that 
we want in the query.  

 Double left click on Album.  



 Double left click on Songs. 

 In the Show Table box, click Close.  

 The Album and Songs relationship will appear in the Query box.  

 In the Album, double left click on the “Artist” field. This will place the Artist field in the first 
column below.  

 In the Songs, double left click on the “Title” field.  

 In the Album, double left click on the “Format” field. *The Format field is my criteria field. I 
want to display all my digital songs in one datasheet.  

 In the Format column, deselect the check mark in the “Show” field. *Since we are going to 
display all our digital songs, we really do not need the word digital to display. We already know 
that these songs are in the digital format. Taking the check mark out of the Format column will 
hide the word digital in our query! 

 In the Format Column, click in the Criteria Field. *This is where we will set the query criteria to 
search ONLY digital songs.  

 Click on the Expression Builder command button in the Design Tab -> Query Setup Group. 

 In the Expression Builder, double click the Tables Folder.  

 We know that the Format field is in the Album Table so double click on the Album Folder.  

 In the second box in the Expression Builder, double click the word “Format.” The code appears 
in the top box of the Expression Builder.  

 Click the Equal Symbol button in the Expression Builder.  

 Type Digital -> Click the OK Button in the Expression Builder.  

 The Format Code will appear in the Format Column on the bottom of the Query Design.  

 Click inside the “Or” field to display the whole code.  

 Click the Run Command Button on the Ribbon -> Design Tab.  

 A list of all your Digital Song Titles and Artists will display in the Datasheet View!  

 SAVE THE Query. Click the Save diskette in the Quick Access Toolbar. Name the Query “Digital 
Songs.” The query will appear in both the Album and Songs area in the Navigation Pane because 
the query uses fields from both tables.  

 
7.) Simple Queries with the Query Wizard 

 The Query Wizard allows you to create four different types of queries. 1. The Simple Query 
Wizard allows you to select fields from all related tables and place all that information in one 
place.  2. The Crosstab Query allows you to create a query where selected fields are column and 
row headers like a spreadsheet. In other words, in Excel the ABC and 123 headers are your 
selected fields.  3. Duplicate Query allows you to find duplicate records within a table. 4. 
Unmatched Query allows you to find orphan records.  

 In this exercise, we are going to create a simple 
query.  

 Close all tables, forms, and queries.  

 Go to the Create Tab -> Query Wizard 
Command Button.  

 The New Query dialogue box will appear.   

 Highlight Simple Query Wizard and click OK.  

 In the Simple Query Wizard dialogue box, we 
get to select when fields from different tables 
and queries we want to add to this particular 
query.  



 In the Tables/Queries box, change this to Table: Album.  

 Move Album Title, Artist, Rating, Media Type and Album Cost over to the Selected Fields box. 

 In the Tables/Queries box, change this to Table: Songs. 

 Move Title, Released Year, Genre, Song Cost over to the Selected Fields box.  

 Click Next. 

 Make sure the Detail (shows every field of every record) is selected.  

 Click Next.  

 Name this Query, “Album & Songs” 

 Click Finish.  

 This is a very quick way to add fields from different tables all into one datasheet! Remember 
that the Album & Songs query is now pinned to the Album and Songs area in the Navigation 
Pane.  

 
8.) Modifying a Query Design 

 What if you wanted the song cost and rating fields added to the Digital Songs query? 

 Open the Digital Songs Query and go to the Design View.  

 Double left click on the Rating Field in the Album table.  

 Double left click on the Song Cost in the Songs table.  

 They will both appear after the Format Column at the bottom of the screen.  

 Left click just above the word “Rating” to highlight the entire column.  

 Left click and hold 
down the left 
mouse button. You 
can now drag the 
column between 
the Title and 
Format field! Drop 
(or let go of the 
mouse) there!  

 Repeat the same 
steps for the Song Cost field.  

 Now that we have the rating field in our query, we can now sort the entire query 
by rating! 

 Click inside the Rating column, Sort Field. A drop down button will appear.  

 Click the drop down button and select Ascending. 

 Save your query here!  

 Go back to the Datasheet View.  

 We should now have each song arranged by rating. Also the Rating and Song Cost fields 
should be in our query.  

 What if you wanted to add up the total amount of money it will cost to buy each song one more 
time? In other words, if we were to add up the Song Cost, how much would that be for just the 
digital music? 

 While in the Datasheet View -> Click the Total Command Button in the Home Tab.  

 Click inside the blank cell (all the way to the bottom) in the Total field.  

 A drop down button will appear. Select SUM.  

 If you do not want the Total, click the Total command button in the Home Tab to turn it off. 



 Save your query again, here!  
 
 
  

 If you wanted to further modify a table. You may add more criteria in the rating field. Notice the 
OR field? In the Format OR field type “Physical.” -> Run the query by pressing the Run command 
button in the Design Tab. Now we have a list of all our Physical and Digital songs! {This really is a 
list of all our songs, but think of the possibilities if you need to filter a field with more than one 
criteria.}  

 

 
 
 
9.) Parameter Queries 

 Parameter queries are essentially filtered queries. You give specific parameters to a query. In 
this lesson we are going to set two types of parameters. The first parameter we will sort songs 
between dates. So if we need songs between 1980 -1999. The second parameter we will sort 
albums and songs by genre by having a prompt ask us what genre we are looking for. As a result, 
you no longer need to create several queries for each parameter that will fill up the navigation 
pane.  

 Close all forms, tables and queries.  

 Go to the Create Tab -> Query Design Command Button.  

 In this first situation, we just want a query to prompt us for song dates. Double Click the Songs 
Table in the Show Table dialogue box.  

 Since we are sorting by song date, we do not need any other table. Click Close to close the Show 
Table box.  

 Double click the Title field.  

 Double click the Released Year field. Remove the Show check mark in the Released Year 
column. 

 Now we have to manually tell Access the criteria. We want songs from and to a specific date.  

 In the Released Year, Criteria Field type: >[Enter Start Year] And <[Enter End Year] 

 Click the Run Command Button in the Design Tab to see the prompts.  

 Enter 1980 in the Enter Start Year 
prompt. Click Ok. 

 Enter 1999 in the Enter End Year 
prompt. Click Ok.  

 You should get a list of songs released 
between the years of 1980 and 1999 
in the datasheet view.  

 SAVE THE QUERY HERE! Click the Save diskette in the Quick Access Toolbar and name the 
Query: Songs by Year. 



 Now every time you need a collection of songs by year you just need to enter the “to” and 
“from” dates in this query. You DO NOT need to create separate queries for each decade or 
single years.  This parameter query will do that all for you.  

 Close the Songs by Year query.  

 You may create queries that only have one parameter. For example, what if we want just a list 
of all our dance songs? We will create a parameter query for this.  

 Go to the Create Tab -> Query 
Design Command Button.  

 Double Click the Songs Table in 
the Show Table dialogue box.  

 Double Click the Album Table to 
add it to the query.  

 Click Close to close out the Show 
Table dialogue box.  

 Double Click Album Title and Artist 
in the Album Table to add these 
fields to the query.  

 Double Click Title and Genre in the Songs Table to add these fields to the query.  

 In the Genre Column, Criteria Field type: [Enter Genre] 

 Press the Run Command Button in the Design Tab on the Ribbon.  

 In the Enter Parameter Value dialogue box, type Dance. 

 Click OK.  

 In the Datasheet View, we now get a list of all our Dance Music! 

 SAVE THE QUERY HERE! Name the Query: Query by Genre. 
 
10.) Reports 

 Reports are a collection of information from the database displayed in a nice way that is easy to 
print!  

 Click on the Artist Table in the Navigation Pane. We are going to create an artist report.  

 Go to the Create Tab -> Report Command Button.  

 A simple report in the Layout View will appear.  

 In the Home Tab -> View -> Print Preview View this is how the report will print out.  

 You can add modifications to this report to make it a look more pleasing. Close Print Preview.  

 In the Home Tab -> View -> Layout View you will see the report snap to the grid.  

 In the Format Tab -> AutoFormat Group, change the AutoFormat to Civic. 

 In the Format Tab -> Click the Logo command 
button.  

 Attach the musiclogo.jpg picture.  

 Double click on the report title “Album”. You can 
now rename the report. Type Artist List. 

 Click on the last name Minogue. All other names in 
the last name column will highlight. Change the font size to 20 and font style to Consolas. *Do 
the same for the first name. Notice all names will resize and restyle.  

 Bold all names by clicking on a name in the first and last name columns and pressing the bold 
command button in the Format Tab or pressing CNTRL+B on your keyboard.  

 To remove a field in the report: Go to the Design View.  



 This report has a counter that adds the number of artists.  

 Click inside the “Count” box and press the Delete Key on your keyboard.  
Make sure only the “=Count” is surrounded with the orange box.  

 Go back to Print Preview. These are your changes.  

 Close Print Preview.  

 SAVE THIS Report! Click on the diskette in the Quick Access Toolbar. Rename 
this report Artist List.  

 The report will appear in the Artist area in the Navigation Pane.  
 
11.) Report Wizard 

 The Report Wizard is a simple way to create modified reports. In this situation, 
we are going to create an album list with the album title, artist, rating, album cost and cover 
image.  

 Close all reports, queries, tables and forms.  

 Click on the Album Table in the Navigation Pane 
to highlight it.  

 Go to the Create Tab -> Report Wizard.  

 The Report Wizard dialogue box will appear. In 
the Tables/Queries selection box, make sure 
Table: Album is selected.  

 Move Album Title, Artist, Rating, Album Cost 
and Album Cover over to the Selected Fields 
box.  

 Click Next.  

 Do you want to add any grouping levels? Yes, 
let’s sort this form by Artist. Select the Artist 
option -> click the right pointing arrow. It looks 
like this: >  

 Click the Grouping Options button on the 
bottom of the Report Wizard box.  

 The Grouping Intervals box will appear. In the Grouping Intervals drop down box, change 
Normal to 2 Initial Letters. *This will sort our report by the Artist’s first two initials.  

 Click Ok.  

 Back in the Report Wizard box, click Next.  

 Now let’s sort this report even further. Change 1. Artist and 2. Album Title to sort by artist then 
by the artist’s album titles.  

 Click Next.  

 We will keep the Layout to Stepped. Click Finish.  

 The report will appear in the Print Preview view.  

 Close Print Preview and go to the Layout View.  

 Now in Layout View, we can modify the report like in the previous lesson.  

 In the Format Tab -> AutoFormat Group, change the format to Verve. 

 Double click on the title “Album” and change it to Album Report.      

 Click on any of the artist’s name (like Kelis). You can resize the 
width of the columns by clicking on the orange lines and 
dragging it in or out with your mouse. 

 Change the font size to 20. 

Grab to resize 



 In the Gridlines Group, click the Gridlines command button and select Vertical.  

 Click on any dollar amounts on the report. Like $7.99. In the Grouping & Totals group in the 
Ribbon, click the Totals command button, and select Sum. *If the totals are adding in unusual 
places, you may need to delete the =Sum([Album Cost)] from the Design View in the Artist 
Footer field.  This will add up the cost of the albums at the bottom of the report.  

 Go back to Print Preview.  

 SAVE your report here. Name the report “Album Report.” *If you wanted to further format and 
modify your report you can use the Property Sheet. If Album Report is still open. Go to the 
Layout View -> Arrange Tab on the Ribbon. In the Tools group there is a command button called 
Property Sheet. Click on the Property Sheet button; it will appear on the right side of the report 
like a task pane. Depending on what you have selected on your report that will appear in the 
Selection type box in the property sheet. This is where you can manually change properties in 
any field on a report.  

 
12.) Reports from Scratch, Printing, Exporting to PDF 

 So far we have only created reports that contain fields from one table. Now let’s create a report 
that will contain fields from two tables. You can do this type of report from the Report Wizard. 
However, let’s create a report from scratch. In this situation, let’s create a “Songs Report” that 
has song title and cost. Also, let’s add album title, artist and cover art.  

 Close all tables, forms, queries and reports. 

 Click on the Songs Table to highlight the table. Do not open the table. 

 Go to the Create Tab -> Reports Group -> Blank Report.  

 The Field List pane will open on the right side of the screen.  

 Double Click on Album to open the fields.  

 Drag and drop Album Title onto the blank report.  

 Drag and drop Artist onto the blank report.  

 Double Click on Songs to open the songs fields.  

 Drag and drop Title onto the blank report next to 
the Artist field.  

 Drag and drop Song Cost onto the blank report.  

 Go back to the Album field list and drag and drop 
the Album Cover field. It should look like this: 

 In the Format Tab in the Ribbon, click on the Add 
Existing Field button to close the fields pane. *If you needed to add more fields from this point 
on, you simply click the Add Existing Field button to open the field pane. Then drag and drop the 
field you want to add onto the report just like we did in this exercise with the Album Title, Artist, 
Title and Song Cost fields.  

 In the Format Tab -> AutoFormat: change to Metro.  

 In the Format Tab -> Controls Group -> Logo. Use musiclogo.jpg that is saved in your documents 
folder in this class.  

 In the Format Tab -> Controls Group -> Title. You can now type in a title for the form. The title 
will be Songs Report. 

 In the Format Tab -> Controls Group -> Page Numbers. In the Format section of the Page 
Numbers box select Page N of M  and Alignment Right. Click OK.  

 In the Format Tab -> Controls Group -> Date and Time. The Date and Time dialogue box will 
appear. Click OK.  



 You can also total up the cost of the songs. Click on one of the dollar amounts on the report. 
This will highlight the entire Song Cost field. In the Format Tab -> Grouping & Totals group -> 
Select Sum.  The total amount will appear at the bottom of the report.  

 You can group and sort the report by any field as 
well. Just like the way we sorted reports with the 
Report Wizard. In the Format Tab -> Grouping & 
Totals group -> Press the Group & Sort Button. 
This will bring up the Group and Sort buttons at 
the bottom of the report.  

 Click on the Add a group button.  

 Click the Select Field button and select Album Title. This will group all 
our songs by album! 

 Click any of the dollar amounts in the report. This will highlight the Song Cost field. Go back to 
the Total button in the Format tab -> Select Sum (Again). This will sum the totals for each 
album as well as give a grand total in the bottom of the report.  

 In the Group, Sort, and Total task bar at the bottom of 
the report, click Add a sort.  

 Select Title. The report will now group by album and sort 
by song title. *Now may be a good time to adjust the 
column width for each field. There is a lot of room on the 
page to increase the size of the cover art and shrink the 
song cost column.  

 Go to the Print Preview View.  

 If you wanted to print this report, simply click the Print command button in the Print Preview 
screen. *The Print Preview screen provides many different options, such as page orientation and 
setting margins, to print better reports if necessary.  

 In the Print Preview screen, you can also publish this report as a PDF. Click on the PDF 
command button in the Print Preview Tab. The Publish as PDF dialogue box will appear. This 
is where you want the document to be saved. In this class, save to the Documents Folder. 
Click Publish when you are finished. The report will open up, ready for you to view!  

 Close the Export – PDF dialogue box. Also, Close the PDF document that popped up on the 
screen. *Next to the PDF command button there are three different buttons that say Word, 
Text File and More. Choosing one of these buttons will allow you to export your report 
directly to Word, Notepad, an XML file and many other formats. Exporting a report to Word 
will save the document as a Rich Text File (.rtf). Try exporting a report to Word after class. 
Click the Word button in the Print Preview tab -> you will get an Export –RTF File dialogue box, 
just name the file and click the Browse button to give it a place to save on your computer ->  
Select “Open the destination file after the export…” -> Click OK.  

 Go back to the Layout View. 

 SAVE and name this report “Songs Report.” *You may notice that the Songs Report shows up in 
both the Album and Songs area in the Navigation Pane. This is because we used fields from both 
tables!  
 

13.) Macros 

 Macros are different in Access than they are in Word and Excel. In 
Word and Excel you use macros to record keystrokes or automate 
tasks. These are helpful if you repeat tasks all the time. However in 



Access, macros allow you automate tasks as actions. In this situation, we can design a button 
[with a macro] that will open the Album Report on the Album w/ Songs form. Even as you enter 
data into the form, the report will automatically update.  

 Close all reports, forms, tables, and queries.  

 Go to the Create Tab -> Other Group -> Macro. Click the Macro drop down arrow.  

 Select Macro.  

 The Macro table appears. In the Action column drop down button, select Open Report. The 
code for opening a report will appear in the Arguments. Leave that alone for now.  

 In the Comment box type: Open the Album Report.   

 At the bottom of the Macro screen, click on the Report Name field -> select Album Report. 

 Change View to Print Preview. *This will open the report in print preview.  

 SAVE the macro. Click the diskette in the Quick Access 
toolbar. Save the Query as “Launch Album Report” 

 Click the Run button in the Design Tab to make sure the 
query is working properly. The Album report should open in Print Preview view. If it opened in 
Print Preview -> Close Print Preview. 

 Close the Launch Album Report Macro. (Right click on the “Launch Album Report” tab and 
select Close.) 

 Open the Album w/ Songs form. (Double click on the form in the Navigation Pane.)  

 Go to the Design View.  

 In the Design Tab -> Controls Group -> Click the Button Command.  

 Draw a button under the Print button or any blank space on the form. The Command 
Button Wizard dialogue box will appear.  

 Under Categories select Miscellaneous.  

 Under Actions select Run Macro.  

 Click Next -> Highlight Launch Album Report -> Click Next.  

 Select Text. Type “Launch Album Report” in the text box.  Click OK.  

 In the meaningful name box type: Launch Album Report. 

 Click Finish.  

 The button should appear on the form. 

 Go to the Form View.   

 Click on the Launch Album Report button. The Album Report should 
open in Print Preview.  

 Click the Close Print Preview button. This should take you back to the 
Album Form. 

 
14.) Automation Macros 

 Notice that every time we enter MP3 in the Media Type field in the 
Album w/ Songs form the Format is Digital. Let’s automate this.  

 With the Album w/ Songs form open, go the Design View.  

 Click in your Media Type field. This will highlight the entire field.  

 In the Design Tab -> Tools Group -> Click the Property Sheet command button to open the 
Property Sheet. *All the properties should appear for the Media Type field.  

 In the Property Sheet, click on the Event Tab.  

 Click inside the On Exit field.  

 Click on the … button.  



 In the Choose Builder box, highlight Macro Builder -> Click OK.  

 In the Design Tab, click on the Conditions button to open that column.  

 In the Design Tab, click on the Show All Actions button so all actions will appear in the Actions 
drop down menu in the Action column.  

 In the first row of the macro, in the comment field type: “Automates Format column when 
digital is typed.” Click on second row field in the Condition column.  

 Click in the second row -> Condition field.  

 Type : [Media Type] in (“MP3”) in the condition field. *If you do not know the code yet from 
previous exercises, you can use the Expression Builder in the Design Tab -> Tools Group.  

 In the Action column, select SetValue. When you choose SetValue, the Item and Expression 
fields open at the bottom of the Macro screen. *This will set the value of the Format field if MP3 
is typed.  

 In the item field, type: [Format] 

 In the Expression field, type: “Digital” 

 Click inside the third field in the Condition column. Under the [Media Type]… text.  

 Type … in the field.  

 In the Action filed, select the GoToControl option. 

 In the Control Name field at the bottom of the macro screen type in: [Condition] *What we are 
doing here is telling Access to automatically type in 
“Digital” in the Format field when MP3 is in Media Type. 
But we are also telling Access to automatically go to the 
Condition field if MP3 is in the Media Type field.  

 SAVE the query here! Click the Save diskette in the Quick Access Toolbar.  

 Click the Close button in the Design Tab. This will take you back to the Design View, Album w/ 
Songs form.  

 Go Back to the Form View. Let’s test the macro.  

 Go to a blank for to enter data. Click on the right pointing arrow with a gold star button in the 

task bar at the bottom of the form.  

 In the blank new form -> in the Media Type field, type MP3 -> Press the Tab key on your 
keyboard. Digital should auto fill in the format field and you should be taken to the Condition 
field ready to enter data in this field. *Close the form. You may need to force the form because 
we enforced integrity last class. Right click on the form tab and select close. A warning will 
appear, tell it yes you want to close.  

 
 
 
 
 
 
 
 
 
 
15.) Auto Exec Macro 

 This macro will open the database directly to the switchboard. So when you need to turn the 
database over to data entry people, they do not have to see the queries, tables, and macros. 



 Close all tables, forms, queries, reports, and forms.  

 Go to the Create Tab -> Macro Button -> Select Macro.  

 Click in the Action column -> Click the drop down button that appears just to the right of the 
column -> select Open Form. 

 At the bottom of the Query screen, click inside the Form Name box, and select Switchboard.  

 Save the Query by clicking on the diskette in the Quick Access Toolbar.  

 Name the macro AutoExec. *If you do not name the macro AutoExec it will not work.  

 Click Ok to save the macro. This macro will appear at the bottom of the Navigation Pane.  

 Close the Macro and Minimize the Navigation Pane.  *Click the double arrow pointing to the 
right at the top of the navigation pane to close it.  They look like this: << 

 Exit the entire database! (Remember where you saved it! In this class I put the database in the 
documents folder.) 

 Open the database. (In this class, double left click the Music.accdb database in the documents 
folder.)  

 You should be taken directly to the Switchboard. *As you probably can tell, this is REALLY 
helpful when you turn your database over to the data entry people. They do not have to see or 
accidently change any tables or queries. They just click on the forms or actions you placed in the 
switchboard!  

 If you want the see the tables, forms, queries, reports and such; just click on the text Navigation 
Pane on the left side of the screen. The Navigation Pane will open up, ready for you to make 
more changes to the database.  

 
16.) Exporting to Microsoft Excel 

 As mentioned before, you can export reports to PDF or Microsoft Word. However, you can also 
export tables and queries to Microsoft Excel.  

 Open the Album Table. 

  In the External Data Tab -> Export Group -> Select the Excel command button.  

 Click the Browse button to select where you want to save the Excel file. In this class, 
save the file to the Documents folder.  

 If you wanted to change the file to a different version of Excel, click the File Format drop down 
button and change that there. In this class, let’s leave it alone.  

 Click inside the empty box next to Export data with formatting and layout. This will insert a 
check mark. 

 Click inside the empty box next to Open the destination file after the export operation is 
complete.  

 In the Export – Excel Spreadsheet click Ok. 

 The Excel Spreadsheet will automatically open up. Now you are able to work with the table in 
Excel!  

 At the bottom of the screen the Access Window should be flashing. Click on the Access Window 
at the bottom of the screen.  

 Click Close. This will close the Export – Excel Spreadsheet box. *Before you click the Close 
button, there is a selection option to save your export. If you click inside the empty box then 
close the Export – Excel Spreadsheet, you save your export! If you look in the External Data Tab -
> Export Group, there is a command button “Saved Exports.” This is where the saved export will 
be placed. Now you can go back to this export every time you need it; instead of having to 
export the table to Excel manually.  



 *You are able to export tables and queries to Word, publish as PDF, etc. However, if you click on 
the More command button in the External Data Tab -> Export Group, at the bottom is the choice 
“Merge it with Microsoft Office Word.” This option will allow to mail merge your data in a table 
using MS Word. If your table had personal contacts such as first names, address, etc, you can 
easily mail merge your list with MS Word to create envelopes, letters, etc. We teach mail merge 
in the Word and Publisher classes at Ela.  

 
17.) Importing an Excel file to Access 

 You can import data from an Excel file directly to a table in Access! This is really handy when you 
created a lot of data that becomes really massive or repetitive in Excel so now you need to 
convert it over to Access. 

 Close all macros, queries, forms, tables, and reports.  

 Click on the External Data Tab -> Import Group -> Excel command button. *Make sure it is 
the Excel command button in the Import Group, not the Excel button in the Export group! 

 Click on the Browse button to find the spreadsheet. *I saved a spreadsheet in your 
Documents folder on the computer. “Music.xls” 

 Make sure the Import the source data into a new table in the current database is selected! 
*With the “Append a copy of the records to the table” will allow you to add records from Excel 
directly onto a table already created in Access. The records in Excel will just add to the bottom 
of the table in Access. 

 Click Ok.  

 In the next screen, make sure First Row Contains Column Headings is checked.  

 Click Next. 

 In the Field Options Group: 
1.) Field Name : Music ID / 
Data Type: Integer / 
Indexed: Yes (No 
Duplicates) *With the no 
duplicates selected we are 
setting this field up as the primary key.  

 Click on Number of Artist -> Change Data Type: Integer. *This is because we only have numbers 
in our field.  

 Click Next. 

 Select Choose my own primary key. Make sure Music ID is selected in the drop down menu.  

 Click Next.  

 In the Import to Table:  type Music.  

 Click Finish. 

 Click Close.  *If you would have selected the Save Import Steps field, then this import will be 
saved!  

 The Music Table should appear at the bottom of the Navigation Pane. 

 Double Click on the Music Table to view the table.  
 
18.) Pivot Charts 

 At this point in the class we should all be familiar with creating charts whether they are created 
in Excel or going to the Design View in Access and selecting the Chart command button in the 
Design Tab on the Ribbon with forms.  Just like in Excel, in Access we can create pivot charts 
(and tables)! You may have noticed that when you edit a table or query -> select the View 



command button in the Ribbon -> There are two pivot options. One is a pivot table and the 
other a pivot chart. These pivot features allow you work with your data in very meaningful ways. 
However, in this class we are going to create a pivot chart by opening a form.  

 Open the Album form from the Navigation Pane.  

 Go to the Create Tab -> Forms Group -> Pivot Table command button.  

 A blank pivot chart will open up.  

 If the Chart List did not pop up when you pressed the pivot chart button, double click the Field 
List command button in the Design Tab.  

 Now we need to think how we want to filer the information. In this instance, let’s filter by album 
counting each album formats by cost. Let’s also show the artist name at the bottom of the 
chart! This is to tell us which format and artist is more expensive when we buy our music.  

 In the Chart Field List Menu drag and drop Album Title to the top “Drop Data Field Here” We do 
this because we are filtering by album.  

 Drag and Drop the Format from the Chart Filed List Menu and drop it in the “Drop Data Fields 
Here” box on top of the chart. We so this because we are counting by album format. 

  Drag and Drop the Album Cost to the “Drop Series Fields Here” box that is on the right side of 
the chart.  

 Drag and Drop the Artist to the “Drop Category Fields Here” box at the bottom of the chart.  

 Mouse over any of the graph lines to view each album count by cost.  

 You can further filter you data by clicking on the drop down buttons next to Album Title and/or 
Album Cost to get at specific data.  

 SAVE you chart. Click on the diskette in the Quick Access Toolbar. Name the chart: Album Chart. 

 By Artist: Artist on top; Count of Cost; side series Rating; bottom Album Title. 
    
   
   Pivot Chart      drop down menus for further filters 

 
 


