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Microsoft Access I 
 

1.) Opening Microsoft Access from the Windows Button 

 Click the Windows Button on the bottom left corner of the desktop screen.  

 Click All Programs -> Microsoft Office Folder -> Microsoft Office Access  
 
2.) Getting Started With Access 

 When you open Access, you have the option to work with pre-made database templates 
or create a new database from scratch.  

 You may click on any templates from the “Featured Online Templates” options if you 
have Internet access or from the “Local Templates” area to find databases already preloaded on 
Office you either downloaded from the Internet or purchased.  

 When using a template, Microsoft assumes that you already know how to modify the  
template to fit your particular needs. *You may find help when using a template on  
Microsoft’s website. www.support.microsoft.com 

 In this class we will create a database from scratch. Double-click on Blank Database. 

 In the File Name box, name your database. In this class, name it “Music” *You may 
notice the file path under the database name. That is where the database will be 
saved. You may click on the folder image to change where you want to save.  

 Click the Folder Icon -> Save to the desktop, and SAVE AS .accdb 

 Click the Create button.  
 
3.) Creating Fields in a Table (All Access databases will have at least one table) 

 After clicking the Create button, a blank table will appear waiting for your data with one field 
(ID) already showing up.  

 Click the Add New Field heading  -> select text. 

 Type in Album Title -> Press the Enter Key 

 Name the other columns by repeating the previous steps:  
-Artist - Rating - Condition – Media 

 Right click the ID field, and select Rename Column. Rename the column to Album ID and press 
Enter. 

 Double click on the New cell. In the Fields tab on 
the ribbon, in the Data Type & Formatting group, 
make sure the Data Type field is showing 
AutoNumber and Unique has a check mark. 
*AutoNumber will assign a unique id number to 
each record which is what we need to create a primary field and key to link other tables. Notice 
the drop down option next to AutoNumber. There are several different options you can select 
to add specific Data Types and formatted data into a field. **We are not checking the “Is 
Required” box in the ribbon for the Album ID field because it is our primary field and does not 
need the box checked. The database will automatically insert unique numbers in each record for 
us.  

 Click on the Album Title field; check Is Required in the Datasheet tab. This will make the field 
required for every record on this table.  

 Click on the Artist field; check Is Required in the Datasheet tab. *We are making these fields 
required for every record on this table. This implies that every album we enter into this table 
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will have a title and an artist. Now what if an album has various artist, such as a NOW That is 
What I Call Music CD. Then we will enter “Various” into the record.  

 Click on the Rating field; change the Data Type to Number because we will rate each album on 
a scale of 1 to 10. -> Leave all other fields alone.   

 
4.) Editing Fields and Saving a Table 

 To Rename a Field: Right click on the word Media.  -> Select Text -> type Media Type. This field 
will tell us if our album is a CD, MP3, Vinyl or other format.  

 Double Click on the Add New Field text. Select Text. Type Format -> Press the Enter Key. This 
new field will tell us if the album is digital, physical or both.  

 To move the Format field before the Media Type field, simply hold down the left mouse button 
just below the text “Format” and drag the mouse in-between the Condition and Type fields and 
let go of the mouse button.  

 To delete a field, simply right click on the field title and select Delete Column.  Right Click on the 
Condition field. Select Delete Column. The column will be removed. *Now look at the Undo 
button on the Ribbon. In most cases, it is grayed out. Meaning, you cannot ‘undo’ the deleted 
column when there are no records in the field. We will have to retype the Condition field and 
move it back.  

 The easiest way to save the table is to go to the Quick Access Toolbar on the upper left hand 
corner of the Access screen and click on the diskette. *I recommend using 
the Quick Access Toolbar to save because we will be saving very often to 
update changes to our database. However, you can still use the Office 
Button to save.  

 Click the Save Diskette on the Quick Access Toolbar -> Name the table Album -> 
Click the Save Button. In the left navigation bar to the left of the Access screen, 
you will see Table 1: Table change to Album : Table.  

 So far your table should look like this:  

 
 
5.) Entering Records into the Album Table 

 The Album Table looks very similar to a spreadsheet that we have seen in Excel. It is broken 
down into columns and rows. However, each row is considered a record. Now, data entry!  

 Click on the first record under Album ID if you are not there and press the Tab Key to move over 
to Album Title. Type Aphrodite and press the tab key.  

 The Album ID auto filled with a unique number and the New went down a row.  

 Artist is Kylie Minogue -> Tab 

 Rating-> 10 ; Condition -> Excellent ; Format -> Digital ; Media Type -> MP3 

 After typing MP3, press the Enter key to move down to the next record.  

 Press the Tab key to move to the Album Title field in the next record.  
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 Album Title -> Fame Monster / Artist -> Lady Gaga / Rating -> 7 / Condition -> Good / Format -
> Physical / Media Type -> Picture Vinyl  

 Type in the following two records:  
  

 

 You may double click the vertical line between fields or grab the line and stretch the column if 
your data does not fit in a field.  

 
6.) Editing/Deleting Records in a Table 

 To fix a typing error in a record, simply double left click on the cell and retype.  

 Double left click in the Rating field for Body Talk, Robyn record.  

 Change the 7 to a 5 -> Press the Enter Key to get out of that particular cell.  

 The Spell Check command in Access 2007 is located in the Home Tab, 
not the Review Tab like in other Office products.  

 Click on the Spell Check command to find any spell check errors. *It is VERY important to spell 
all records, fields and other data correctly. Later when we set up forms and queires, they search 
by spellings. So a serach can lose records if there are misspellings!  

 Notice we have two Aphrodite records. Let’s delete one.  

 Left click on the blue box to the left of record 4, column Album ID.   

 Clickin on the blue box selects the entire record. Hit the Delete Key on  
the keyboard. Don’t select delete on the Ribbon!  

 Access will ask if you really want to delete that particular record;  
Click YES. 
 
 
 
 
 

 Type in a new record:  
-Album Name -> Light Years / Artist -> Kylie Minogue / Rating -> 9 / Condition -> Good / 
Format -> Physical / Media Type -> CD.  

 Notice the Album ID goes from 3 to 5. The unique feature will remember ID 4 and not use it 
again. In terms of using this particular field for a key, it does not matter if the numbers are not in 
sequental order. However, they have  to be unique!  

 Save the table.  
 
7.) Formatting Data and Copy/Paste 

 Click into the cell that has the text “Lady Gaga” 
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 In the Home Tab -> click the Bold Command Button. Notice the whole table will Bold. This same 
feature happens when changing text styles, text size, text color, etc. Press the Control Key and 
the letter B on your keyboard to un-bold your text.  

 However, the text align options are separated by fields. For example, Click anywhere inside the 
rating field -> Click the Text align center button in the Home Tab.  

 To Copy and Paste a record, let’s pretend we have the Aphrodite album as a vinyl record  
as well. Right click the light blue box to the left of Album ID 1.  

 Select Copy. 

 Right click on the light blue box that has the star, and select paste.  

 Now change the Media Type field in this new record to vinyl and Format to physical.  
 
8.) Data Type Options 

 By now, you may realize that DATATYPES are extremely important to maintain your data 
integrity. However, you may add new data types. *Remember the term “Data Integrity.” We 
are going to discuss this far more in-depth the coming lessons.  

 In the Datasheet Tab -> View Command Button -> Select Design View. 

 Your table moves to the “Design View”  

 Field Name: The name of individual fields in a database appear here. 

 Data Type: If you click on any of the data type fields, you will notice a  
drop down button to the right of the field. You can select the type of data each field will 
represent in the database. For example, in the rating field, it will always be a number. That is 
why we change it to Number. 

 Description: This is a description of individual fields that will appear in the task bar on the 
bottom of the Access screen. Descriptions are not required.  

 Click the empty field box under “Format” and type Album Cover.  

 Click in the Data Type field and change the option to “Attachment.” 

 If the attachment option is not there you need to save the whole database as .accdb database.  
To save the WHOLE database, click on the Office button on the upper left of the Access screen. 
Go to Save As -> Change Music.dcb to Music.accdb and click SAVE. 

 Go back to the Design View -> Album Cover-> 
Data Type Options -> Change to Attachment 

 Go back to the View Command in the Ribbon. 

 Change your view back to Datasheet View 

 You will have to save all your changes -> Choose Yes when prompted to Save. 

 You will notice the Album Cover field change to paper clips. 

 Now let’s insert the album cover images.  

  Double left click on the paperclip in the first Aphrodite record. 

 The Attachments dialogue box will appear. 

 Click Add -> Locate the image on your computer -> click Insert ->  
the attachment will appear in the dialogue box.  

 Click OK 

 Look at the Album Cover field. Notice the number next to the paperclip will change to (1)! 

 Now place the Fame Monster Album cover into the field.  
 
9.) Find/Replace  

 The Find and Replace command buttons in the Home Tab in the Ribbon 
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allow you to find records or change an item(s) in a field. This works great 
when you have a database with hundreds of records.  

 Click the Find command button.  

 The Find and Replace dialog box will appear.  

 Type Kylie in the Find What box.  

 Change Look In from Album ID to Album. *This is so we search the entire table not just the 
Album ID field.  

 Change the Match drop down to Any Part of Field. 

 Click Find Next. 

 Look back onto your table, the Find feature found the first record with the term “Kylie.”  

 In the Find and Replace dialogue box, click Find Next.  

 The Find feature will find each record with the word “Kylie” in it. When you click Find Next 
again, you will get the next record.  

 When the Find feature can find no other Kylie record, the pop up box will appear: 
 
 
 

 
 

 Click Ok to get rid of the box.  

 In the Find and Replace dialogue box, click on the Replace tab. 

  On your table, click on the word Condition 
to highlight the entire field.  

 In the Find What box, type: Excellent 

 In the Replace With box, type: Outstanding 

 Click Replace All in the dialogue box.  

 All words that were Excellent change to  
Outstanding!  

 You will be prompted if you want to continue. 

 Click Yes. 

 The warning box that appears when you Replace All states “You won’t be able to undo this 
Replace operation.” Is this really true? Not really, you can always replace all to Excellent again or 
manually type Excellent in each record.  

 Press the Cancel button or the red box with a white X in the Find and Replace dialogue box to 
get rid of the box.  

 
10.) Sorting and Filters 

 The sort and filter command buttons are located in the Home tab in the ribbon. 
They are highly used when working with a large to huge database. You can sort 
data by particular fields or filter data to fit specific criteria.  

 To sort by a field, click on the Format field to highlight the whole field.  

 Click the A-Z sort command button.  

 The field sorts alphabetically.  

 Each field has its own sorting button.  

 Hover your mouse over the right side of the Artist field.  

 Now you can sort by individual entries in a field.  
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 Deselect all options in the Artist sort except Kylie Minogue.  

 Click Ok. Just the Kylie Minogue records appear! 

 To get all the records back on your table, click the Select All. 

 Click Ok. All records will appear again.  

 To get rid of your sorts, click on the Clear all Sorts command  
button just under the Z-A sort button.  
 

 To filter a table, first click on a field you want filtered. For example, let assume we what to look 
at all digital albums on our table. This means we need to filter out all physical albums.   

 Click on the Format Field to highlight the entire column.  

 Click the Filter command button in the Home Tab, on the ribbon.  

 Deselect all options except Digital -> Click OK. 

 You may use the Advanced or Wizard filter buttons to get specific searches. They are the 
buttons in the Sort & Filter group that have the lightning bolt and slide screen behind the gray 
filter.  

 When you filter a table, the Toggle Filter command button will activate.  

 To get rid of your filter, simply click on the Toggle Filter button. All records will return to your 
table. *If you click the Toggle Filter button again, the table will revert back to your last filter. In 
this case, it will go back to filtering out the physical formats.  

 Try filtering the Rating field.  

 Click on the Rating field -> Click the Filter command button -> Select Number Filters -> Choose 
Between -> Type 6 in Smallest -> Type 9 in Largest -> Click OK 

 Just your albums with ratings between 6 and 9 will appear in  
your table. As you can probably tell by now, this a powerful 
tool when you are organizing information with a lot of data  
or working with a huge database. 

 
 

11.) The IMPORTANCE of Data Integrity   

 When setting up your database, it is very important to think about what type of data is inputted 
in each field. For example, you may notice that our rating system is a number system with 
numbers between 1 and 10. Well, we do not what anyone to mistakenly put the date or the 
number 15 in that field. That is considered invalid data! You always want to avoid invalid data 
because your whole database loses its integrity when invalid data is entered into tables. So we 
will have to set data rules and input masks so we do not “accidently” input invalid data into 
any of our fields.  

 To set data integrity we need to go back to the Design View.  

 In the Home Tab -> Click View -> Design View 

 Click on the Data Type field for Rating 

 At the bottom of the screen, two tabs appear. We need to be in the General tab.  

 Click the drop down box to the right of “Long Integer” and change 
it to Integer. We are only working with numbers  
between 1 and 10. We do not need long numbers.  

 Change Format to Fixed Number. We are not working with  
currencies or decimals.  

 Change Decimal Places to 0. (Only numbers 1-10).  
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 Go down to Required. Is a rating always required for this field? 
If yes, change the required entry to YES.  

 Will most of your music have a similar rating all the time? In other 
words we can set a default to always appear in the rating field, we 
will just have to change it when the rating is different.  

 In the Default Value field, type the number 5. 5 will appear in each 
record for now on as it is now our default value.  

 Now, SAVE your work! 

 A warning will appear letting us know that data integrity has changed. Click YES.  

 Go back to the Datasheet View. [Home Tab -> View -> 
Datasheet View] 

 Observe the Rating field in the “new” record.  

 The number 5 appears as our default number for the field.  
 
12.) Input Masks  

 Input masks are important to format data in one particular way. For example, an input mask will 
tell you or anyone inputting data into the table that the way to format a date is 08/13/2010 NOT 
August 13, 2010 or 8-13-2010. Input masks are broken down into three pieces separated by 
semi-colons. The input mask we are going to use is: 09;1;_ 

 Go back to the Design View -> Rating Field -> Input Mask -> Type 09;1;_ 

 The first part of the input mask is 09. The 0 tells Access that the rating field MUST start with a 
digit. The 9 tells Access that a second digit is Optional. Our rating system is a series of numbers 
between 1 and 10. Not all ratings will have that second digit. However, this does not tell Access 
that we do not want 11 typed into our rating field. (We come back to that in a bit.)  

 There are several other input markers used. You can find a list of different markers for required 
or optional letters, phone numbers, symbols, etc. at http://office.microsoft.com/en-us/access-
help/control-data-entry-formats-with-input-masks-HA010096452.aspx 

 The second part of the input mask you can only input 0 or 1. If 0 is selected, then the data in the 
field will be stored with the database. If 1 is selected, the data in the field is NOT stored with the 
database but will still be displayed. This is used if you need to free up space in a large database.  

 The third part the input mask is simply a marker to help the data entry person know to type 
something in the field. In our input mask, we have an underscore _. When we type a new record 
an underscore will appear in the rating field letting us know to type data.  

 SAVE YOUR TABLE AND GO BACK TO THE DATASHEET VIEW.  

 Type in a new record:  
Album Title: Body Talk 2 ; Artist: Robyn ; Rating 10 ; Condition: Outstanding ; Media Type: 
MP3 ; Format: Digital. *Notice when typing the rating into the field. Two underscores appeared 
letting us know to enter data. If you go back and delete the first number and try to leave the 
record, you will be prompted that is not allowed.  

 Change the rating from 10 to 7. Make sure to change the first digit to 7 and delete the second 
digit!  

 
13.) Data Validation  

 Data validation will tell Access that only certain characters belong to a particular field. In other 
words, we do not want the numbers 11-99 in our rating field. We will have to limit the numbers 
that go into this field. We do that with data validation.  
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 Go back to the Design View -> Rating Field -> Validation Rule -> Click the … button on the right 
side of the field. 

 
 

 The Expression Builder dialogue box will appear. This is where we will tell Access to only allow 
numbers 1 – 10 into this field.  

 You can different validation expressions by double clicking the Function folder -> Built-In 
Functions. However, we will type in our expression.  

 In the white box on the top part of the Expression Builder box, Type 1 -> Click the Or button -> 
Type 2 -> Click the Or Button -> Type 3 -> Click the Or button -> Type 4 -> Click the Or button -
> Type 5 -> Click the Or button -> Type 6 -> Click the Or button -> Type 7 -> Click the Or button 
-> Type 8 -> Click the Or button -> Type 9 -> Click the Or button -> Type 10  

 The Expression Builder will look like this: 

 Click the OK button in the Expression  
Builder. 

 The expression is now in the Validation 
Rule field!  

 In the Validation Text field type: 
“Please enter a number 1 – 10” 

 The Validation Text field will pop up a warning box to inform the person that only a number 
between 1 and 10 allowed into this field.  

 The General Tab for the Rating field should 
look like this so far:  
 
 

 SAVE your table. You will be prompted 
that data integrity rules have changed.  
Click YES.  

 Go back to the Datasheet View. [Home tab-> 
View Button -> Datasheet] 

 Let’s enter a new record into our table. 

 New record: Ray of Light ; Madonna ; 11 ; Picture Vinyl ; Physical ; Good 

 When typing in a new record -> the in rating field type 11.  Notice you cannot use 11. Change 
the rating to 7. 

 
 
 
 
 
 
 
 
 

 For text validation Rules, quotes are needed when manually typing an expression in the 
validation rule field or the expression builder will put them in for you: “Physical” Or “Digital” 
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 If time allows, change the Validation Rules for the Media Type, Format and Condition fields. If 
we only have certain media types [MP3, CD, Picture Vinyl, etc.] make those the only options in 
the Media Type field.  

 There are only two conditions [Physical and Digital]. There are only certain types of conditions 
[Outstanding, Good, Fair, Poor]. Can you make those Validation Rules? 

 Hopefully, by now you see the IMPORTANCE of data integrity (especially validation rules). 
Validation rules will not allow misspellings or unneeded numbers. For example, you cannot 
enter Vinly in the Media Type field. You will be prompted to fix that error. Without data 
integrity, a database can eventually be useless to completely fall apart.  

 
14.) Data Entry 

 So far in this class we have only worked with one table. Let’s add some more data to the Album 
table. 1.) Add a new field titled Cost. For each record: a CD costs $7.99, a MP3 costs $9.99, a 
vinyl costs $20.99 and a picture vinyl costs $25.99. 

 Do you remember how to add the dollar signs to field? Go to the Design View -> Click in the 
Cost field -> Go to the Format rule at the bottom of the screen and change it to Currency.  

 Go back to the Datasheet View -> let’s add two more records. The table should like the 
following:  

 
 
 
 
 
 
 
 
 
 
 
 
15.) Adding Tables 

 Now that we have enough data on the Album table, we need to create two more tables to turn 
this database into a relational database and see how we turn the “flat table” into relationships.  

 When planning a database, you have to think how to break down your data. For this database, 
each album contains songs and artists. Songs and Artists will be two other tables.  

 Click the Create Tab on the Ribbon -> Click the Table command button.  

 A new table will appear in the Navigation Pane.  

 This table will be our Songs table.  

 Name each field: Songs ID, Title, Released Year, Genre, Artist ID, Album ID. 

 Save the Table ; Rename the table “Songs”  
 
 

 
 

 Click the Create Tab on the Ribbon -> Click the Table command button.  

 A new table will appear in the Navigation Pane.  

 This table will be our Artist table.  
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 Name each field: Artist ID, Last Name, First Name, Primary Genre  

 Save the Table ; Rename the table “Artist”  
 
 
 
 
 
16.) Creating Relationships and Keys 

 You may have noticed when we looked at the Design View in the Album table; there was a Key 
next to the Album ID field. This is the table’s primary key.  

 Primary keys connect each table. This is why we have a unique album ID, songs ID and artist ID. 
Each unique ID will connect data between tables.  

 Go to the Design View in both the Songs and Artist tables. Make sure Songs ID and Artist ID 
have the primary key symbol. *If there is no key symbol next to the field you need to be the 
primary field, simply click on the field and click the Primary Key command button in the Design 
Tab on the Ribbon -> Primary Key command button to activate the primary key.  

 While in the Design View in the Songs Table, change the Artist ID and Album ID field to 
Number.  

 SAVE ALL YOU CHANGES HERE!  

 Close all tables. Right click on a table tab -> Select close all. 

 Click the Datbase Tools Tabs -> Relationships Command Button. 

 The Show Table dialogue box appears with all our tables.  

 Click on the Album option and select Add. 

 Click on the Songs option and select Add. 

 Click on the Artist option -> select Add -> Click the Close button to close the dialogue box.  

 The tables appear in the Relationships tab.  

 Rearrange the tables so they are in this order: Album, Songs, Artist. 

 Notice the Primary key in the Albums table matches the Album ID in the songs table? Click and 
drag the Album ID field in the Album table over the Album ID in the Songs table and release. 

  The Edit Relationships box appears! 

 Make sure Album ID in both fields match.  

 Click the box next to Enforce Referential Integrity. 

 Click the Join Type button and select option 2.  
We are choosing this option because we have no  
records in the Songs table.  

 Click OK then click Create in the dialogue box.  

 The relationship should appear like the following: 
 
 
 

1 to Many Relationship 
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  Do you know why this relationship is a one many relationship? Each album has 10 to 20 songs. 
Therefore, in the songs table each song can have the same album title. But in the album table, 
there can only be one album id to identify the individual album.  

 Now join the Artist ID fields between the Artist and Songs table. Make sure to Enforce 
Referential Integrity. 

 In the Join Type button and select option 1.We are choosing this option because we have no  
records in either tables.  

 Click Ok and Create. SAVE YOUR RELATIONSHIPS. *If you wanted to edit the relationship, simply 
double left click on the connectors and the Edit Relationship dialogue box will appear.  

 In the Design Tab click the Close command button. To see the relationships again, click on the 
Database Tools Tab -> Relationship command button.  

 
 
17.) Referential Integrity 

 What if we sell an album and delete it out of our Album table? What happens to all the songs 
from the album in the Songs table? If you do not Enforce Referential Integrity when 
creating the relationships, then the songs become orphans. The more orphan data you 
have in a database, the more your database becomes useless and/or takes up large 
amounts of memory. 

 What if we wanted to change an Album ID in the Album table? In order for the Songs table 
to update automatically, the Cascade Update Related Fields option in the Edit 
Relationships dialogue box needs to be checked.  

 If you want the songs table to automatically update when and album is deleted from the 
Album table, the Cascade Delete Related Records option in the Edit Relationships 
dialogue box need to be checked. 

  If your Relationships are not showing -> Go to the Database Tools tab -> Click the 
Relationships command button.  

 Double left click the black arrow between the album table and the songs table.  

 This will bring up the Edit Relationships Dialogue Box.  

 Click the Cascade Update and Cascade Delete boxes.  

 Click OK -> Do the same for the Artist and Songs table.  

 Click OK -> SAVE YOUR WORK HERE!  
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18.) Sub Datasheets 

 Now that we have relationships established between tables, a sub datasheet will allow us to 
input data in multiple tables simultaneously. For this database, now we can input songs that 
belong to an album. 

 Double click the Album Table in the Navigation Pane to bring the table up.  

 Notice the plus signs to the left of each Album ID. Click on the plus sign next to Album ID 1.  

 The Songs table will appear. Now you can enter album songs.  

 
 

 Type in: Title – All the Lovers / Released Year  - 2010 / Genre – Pop / Artist ID 1 

 When you try to enter a new record, you will be prompt that an error has occurred.  

 The error occurred, because We need an artist ID (or a record) for Kylie Minogue.  

 Go to the Artist table, and make a record for Kylie Minogue, Lady Gaga, Robyn, and Kelis 

 SAVE YOUR ARTIST TABLE! *You will have to remember the Artist ID when inputting that data 
into the Songs Table. Meaning, in the Artist ID field in the songs table, you will now have to 
remember that Kylie Minogue is 1.  

 
 
 
 
 
 
 
 
 
 

 Now go back to the Album Table and continue to add songs: (Songs are below) 
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19.) Forms (part 1) 

 Forms allow a user to input data into a database much like filling out a form online. When you 
fill out a form, it is connected to a database in the background so data that is inputted into the 
form will be added to the data that is already stored in the database. There are two advantages 
with using forms. 1.) A data entry person does not necessarily need to input records into tables. 
They just use the forms to add the records. 2.) Forms are easier to work with, and they are 
cosmetically more pleasing to view instead of a table full of columns and rows. 

 Open the Album table, and close all other tabs in the database.  

 The easiest way to customize a form is to use the Form Wizard.  

 Click the Create Tab on the Ribbon ->  Form Wizard. 

 The Form Wizard Dialogue Box will appear.  

 The Album Table will appear in the Tables/Queries drop down because we opened it earlier.  

 In the Available Fields box, we get to manually select which fields we want in the form.  

 Select Album Title and click the single right arrow 
in the Form Wizard.  

 Select Artist, Rating, Media Type, Album Cover and 
Cost and move them over to the Selected Fields box.  

 Click the Next Button. 

 You now get to choose how you want to layout your form.  

 Click Justified.  

 Click the Next button.  

 Select the Metro option.  

 Click the Next button.  

 In the “What title do you want for you form” box, name the form Album.  

 Click the Finished button.  
 
20.) Simple Form Editing 

 The newly created Album form more than likely formatted oddly. 

 Go to the Design View in the Ribbon.  

 You may notice that each field turns into a text box. Each text box can be 
resized to properly fit the form. However, the blue bar that states Form 
Footer can also be lowered. Hover your cursor just to the top of the 
Form Footer bar and it turns into a double arrow pointer. Hold down 
your mouse button and drag the footer down to open more space for 
the album art.  

 Go back to the Form View. [Home tab -> View Button -> Form View] 

 There are several more editing, formatting and features options with forms that we will cover in 
the next class.  

 
21.) Searching and Creating Records with Forms 

 At the bottom of the Form View, in the status bar, there are several buttons to move through 
forms and a search box.  

 
 Type Madonna in the search box and press the Enter key on your keyboard.  

 This search will  bring you to the first Madonna record.  
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 If you press the right or left arrows, they will take you to the next or previous record.  

 If you press the right or left arrows with lines in front, they will take you to the first and last 
record on the table.  

 Press the right pointing arrow with a star next to create a blank form. 

 This is where you can type a new record that will input data into the  
Album  table.  

 Type a new Record! : Album Title: X / Artist : Kylie Minogue / Rating : 9 / Media Type : CD / 
Double click inside the Album Cover box to open the attachment dialogue menu -> Attach X.jpg 
-> Cost : $7.99 ->  Press the Enter key on your Keyboard.  

 You will be moved to a blank record! Click the left pointing arrow in the status bar to see the 
record you just created!  

 
22.) Switchboard (Only if there is Time in Class) 

 The switchboard is important, because it 
allows a user to find forms by clicking a 
button. However, in previous versions of 
Access, the Navigation Pane did not exist. A database designer would have to 
create a switchboard to allow users to navigate between forms to enter new 
records. In order for the switchboard to work, we need to create forms for the all 
three tables. The Album table already has a form, so we really just need to create 
a form for the Songs and Artist tables. **Double click on the Songs Table in the 
navigation pane to open the songs table. On the Ribbon, click the Create tab -> 
Form command button. Next, click the save diskette on the top left corner of the 
Access screen and save the form Song.  ***Repeat these same steps for the 
Artist table, but name the form Artist. Your navigation pane should look like:  

 

 Close all tabs in the database. [Right click on a tab and select close all]  

 Click the Database Tools tab on the Ribbon. 

 Click the Switchboard Manager command button 
In the Database Tools group.  

 You will be warned that The Switchboard Manager 
was unable to find valid switchboard in the database. CLICK YES!  

 The Switchboard Manger Dialogue box will appear.  

 Click the Edit Button. Under Switchboard Name, change it to Music. 

 Click the New button.  

 Another box will appear. In the Text box type Add new Albums. 

 Click the Command drop down arrow and select Open Form in Add Mode.  

 Click the Form drop down arrow and select Album.  

 Click OK. 

 Click the New button.  

 Another box will appear. In the Text box type Add new Songs. 

 Click the Command drop down arrow and select Open Form in Add Mode.  

 Click the Form drop down arrow and select Songs.  

 Click OK 

 Click the New button.  

 Another box will appear. In the Text box type Add new Artists. 

 Click the Command drop down arrow and select Open Form in Add Mode.  
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 Click the Form drop down arrow and select Artists.  

 Click OK 

 The Edit Switchboard Page box should look like this:  

 Click the Close button in the Edit Switchboard Page box.  

 The Switchboard Manager box changes to Music.  

 Click the Close button on the Switchboard Manager box.  

 The Switchboard now appears in our Navigation Pane on the left side of the Access screen.  

 Click the Switchboard Form in the Navigation Pane.  

 Click on Add new Albums.  

 A blank form should appear and is now ready for you to enter data.  

 Now every time you open this database, the switchboard will appear.  
This is so that a person who does not know Access well can just open a form directly from the 
switchboard and enter data from there instead of using tables or other features in Access a 
person may not know.  

 
[Advanced Form Technique that will be covered more in the next class:  
Open the Album Form -> Go to the Design View -> In the Design Tab, click the Button command in the 
Controls group -> draw a button on the form -> When you finish drawing a button the Command Button 
Wizard box appears -> In the Categories box, select Form Operations -> In the Actions box, select Close 
Form -> Click Next -> Click Next again -> Type “Close Form” in the text box under the “A meaningful 
name will help…” -> Click Finish.  
Return to the Form View -> Click the new button on the form -> The form will close and take you back to 
the switchboard. ] 
 
 
 
 
 
 
 
 
 
 


